Hive Thrift Server takes Forever to Start



0
Hi,

I tried to run the following command to start the Hive Server , in order to create a remote connection:

$ HIVE_PORT = 8888
$ hive --service hiveserver

It shows this message and takes a pause forever. Neither it is giving any error message like error during startup.

"Starting Hive Thrift Server"


I googled about it and found that , Ideally it should give this message on startup:

Starting Hive Thrift Server
12/07/03 08:07:11 INFO service.HiveServer: Starting hive server on port xxxxx.

Appreciate any insight on this issue.



2 Answer(s)


0

hi Shubhankar,

The command would generally give the message "Starting Hive Thrift Server" which you already were seeing. The messages would change with some Hive versions.

Execute the command to confirm whether any service is running
netstat -nl | grep 8888

Thanks

0

When I run the command netstat -nl | grep 8888 , it goes back to the shell command without giving any output message.

I closed my VM session and restarted in order to kill any process which might have blocked. Still getting the same issue with the HiveServer.

I am clueless on what is the problem. Please help.

Your Answer

Click on this code-snippet-icon icon to add code snippet.

Upload Files (Maximum image file size - 1.5 MB, other file size - 10 MB, total size - not more than 50 MB)

Email
Password