AMBARI Failed to Start



0
Hi,
I have the same problem where ambari will not start. I to look in /var/log/ambari-server/ambari-server.out and saw:

Errow occured during inialization of VM
Could not reserve space for object heap
Error: Could not create the Java Virtual Machine
Error: A fatal exception has occured. Progam will exit.


I have 8GB Ram machine, which I bought just for Hadoop. Based on my research, I to set JAVA_OPTIONS on windows through the Control Panel as well as in my /etc/profile file.

export JAVA_OPTIONS="-Xms256m -Xmx2048M"

This still does not work. Please let me know if this is a viable solution.
Thanks,
Mike C


1 Answer(s)


0

I found the solution and was able to start ambari:

1. Tested to see wht JAVA heap gives the error by
$ java Xmx512m -version
(I tried different number and found that 1024 worked for me)
2. cd /var/lib/ambari-server
3. I backed up the ambari environment file before making changes
cp -pr ambari-env.sh ambari-env.sh_bck
4. vi ambari-env.sh and look for line that sets JAVA heap size
edit line to: export AMBARI_JVM_ARGS=$AMBARI_JVM_ARGS' -Xms512m -Xmx1024m
:wq! (to exit and save file)
5. Now do $ambari-server start
The will successfully start ambari
Thanks,
Mike