1-844-696-6465 (US)        +91 77600 44484        help@dezyre.com

HBase not running in VM



0

hbase(main):001:0> status
16/10/03 18:56:15 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/03 18:56:16 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/03 18:56:17 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/03 18:56:19 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
 

 

hbase(main):002:0> version
0.94.6-cdh4.4.0, rUnknown, Tue Sep  3 20:09:51 PDT 2013
 

http://localhost:60010/master-status

and

http://localhost:60030/rs-status

return unable to connect

 

please can you help on this


3 Answer(s)


0

Hi Subhra,

By default, the value of zookeeper.znode.parent is /hbase

Please add the following property to the hbase-site.xml:

<configuration>
        <property>
                <name>zookeeper.znode.parent</name>
                <value>/hbase-unsecure</value>
        </property>
</configuration>

Hope this helps.

Thanks.


0

I did this change

then

 

hbase(main):001:0> version
0.94.6-cdh4.4.0, rUnknown, Tue Sep  3 20:09:51 PDT 2013

hbase(main):002:0> status
16/10/16 18:22:19 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:20 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:21 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:23 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:25 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:29 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.
16/10/16 18:22:33 ERROR client.HConnectionManager$HConnectionImplementation: Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.

ERROR: org.apache.hadoop.hbase.MasterNotRunningException: Retried 7 times

Here is some help for this command:
Show cluster status. Can be 'summary', 'simple', or 'detailed'. The
default is 'summary'. Examples:

  hbase> status
  hbase> status 'simple'
  hbase> status 'summary'
  hbase> status 'detailed'

 

 

---------------------------------------------------

 

http://localhost:60010/master-status

and

http://localhost:60030/rs-status

return unable to connect

 

please can you help on this


0

I was able to solve it now by starting the hbase service from cloudera manager.

Didn't need to change hbase-site.xml

Your Answer

Click on this code-snippet-icon icon to add code snippet.

Upload Files (Maximum image file size - 1.5 MB, other file size - 10 MB, total size - not more than 50 MB)

Email
Password