still not able to use oozie



0

sudo su
[root@localhost bin]# ls
oozie  ooziedb.sh  oozied.sh  oozie-env.sh  oozie-sys.sh
[root@localhost bin]# ./oozied.sh start

Setting OOZIE_HOME:          /usr/lib/oozie
Sourcing:                    /usr/lib/oozie/bin/oozie-env.sh
  setting OOZIE_CONFIG=/etc/oozie/conf
  setting OOZIE_DATA=/var/lib/oozie
  setting OOZIE_LOG=/var/log/oozie
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting CATALINA_TMPDIR=/var/lib/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting CATALINA_BASE=/usr/lib/oozie/oozie-server-0.20
  setting CATALINA_OPTS=-Xmx1024m
  setting OOZIE_HTTPS_PORT=11443
  setting OOZIE_HTTPS_KEYSTORE_PASS=password
  setting CATALINA_OPTS="$CATALINA_OPTS -Doozie.https.port=${OOZIE_HTTPS_PORT}"
  setting CATALINA_OPTS="$CATALINA_OPTS -Doozie.https.keystore.pass=${OOZIE_HTTPS_KEYSTORE_PASS}"
Using   OOZIE_CONFIG:        /etc/oozie/conf
Sourcing:                    /etc/oozie/conf/oozie-env.sh
  setting OOZIE_CONFIG=/etc/oozie/conf
  setting OOZIE_DATA=/var/lib/oozie
  setting OOZIE_LOG=/var/log/oozie
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting CATALINA_TMPDIR=/var/lib/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting CATALINA_BASE=/usr/lib/oozie/oozie-server-0.20
  setting CATALINA_OPTS=-Xmx1024m
  setting OOZIE_HTTPS_PORT=11443
  setting OOZIE_HTTPS_KEYSTORE_PASS=password
  setting CATALINA_OPTS="$CATALINA_OPTS -Doozie.https.port=${OOZIE_HTTPS_PORT}"
  setting CATALINA_OPTS="$CATALINA_OPTS -Doozie.https.keystore.pass=${OOZIE_HTTPS_KEYSTORE_PASS}"
Setting OOZIE_CONFIG_FILE:   oozie-site.xml
Using   OOZIE_DATA:          /var/lib/oozie
Using   OOZIE_LOG:           /var/log/oozie
Setting OOZIE_LOG4J_FILE:    oozie-log4j.properties
Setting OOZIE_LOG4J_RELOAD:  10
Setting OOZIE_HTTP_HOSTNAME: localhost.localdomain
Setting OOZIE_HTTP_PORT:     11000
Setting OOZIE_ADMIN_PORT:     11001
Using   OOZIE_HTTPS_PORT:     11443
Setting OOZIE_BASE_URL:      http://localhost.localdomain:11000/oozie
Using   CATALINA_BASE:       /usr/lib/oozie/oozie-server-0.20
Setting OOZIE_HTTPS_KEYSTORE_FILE:     /root/.keystore
Using   OOZIE_HTTPS_KEYSTORE_PASS:     password
Setting CATALINA_OUT:        /var/log/oozie/catalina.out
Using   CATALINA_PID:        /var/run/oozie/oozie.pid

Using   CATALINA_OPTS:       -Xmx1024m -Doozie.https.port=11443 -Doozie.https.keystore.pass=password -Dderby.stream.error.file=/var/log/oozie/derby.log
Adding to CATALINA_OPTS:     -Doozie.home.dir=/usr/lib/oozie -Doozie.config.dir=/etc/oozie/conf -Doozie.log.dir=/var/log/oozie -Doozie.data.dir=/var/lib/oozie -Doozie.config.file=oozie-site.xml -Doozie.log4j.file=oozie-log4j.properties -Doozie.log4j.reload=10 -Doozie.http.hostname=localhost.localdomain -Doozie.admin.port=11001 -Doozie.http.port=11000 -Doozie.https.port=11443 -Doozie.base.url=http://localhost.localdomain:11000/oozie -Doozie.https.keystore.file=/root/.keystore -Doozie.https.keystore.pass=password -Djava.library.path=

Using CATALINA_BASE:   /usr/lib/oozie/oozie-server-0.20
Using CATALINA_HOME:   /usr/lib/bigtop-tomcat
Using CATALINA_TMPDIR: /var/lib/oozie
Using JRE_HOME:        /usr
Using CLASSPATH:       /usr/lib/bigtop-tomcat/bin/bootstrap.jar
Using CATALINA_PID:    /var/run/oozie/oozie.pid
[root@localhost bin]# 
[root@localhost bin]# 
[root@localhost bin]# oozie admin -oozie http://localhost:11000/oozie status
[root@localhost bin]# 
 

 

 

"http://localhost:11000/oozie/"  in browser returns page not found


12 Answer(s)


0

Hi Subhra,

Could you please share the oozie log with me.

Thank.


0

Please find attached the logs from

/var/log/oozie



0

Could you please try using IP address in the web console instead of localhost?

Regards,
Sakhuja


0

tried that, got the following error

 

 

[root@localhost bin]# oozie admin http://192.168.235.128:11000/oozie/ status
java.lang.IllegalArgumentException: Oozie URL is not available neither in command option or in the environment
    at org.apache.oozie.cli.OozieCLI.getOozieUrl(OozieCLI.java:547)
    at org.apache.oozie.cli.OozieCLI.createXOozieClient(OozieCLI.java:719)
    at org.apache.oozie.cli.OozieCLI.adminCommand(OozieCLI.java:1359)
    at org.apache.oozie.cli.OozieCLI.processCommand(OozieCLI.java:518)
    at org.apache.oozie.cli.OozieCLI.run(OozieCLI.java:485)
    at org.apache.oozie.cli.OozieCLI.main(OozieCLI.java:182)
Oozie URL is not available neither in command option or in the environment
 

 

regards

Subhra


0

Hi Subhra,

It seems your hostname is "localhost". Could you please post what's is in "/etc/hosts"? I think you must be having a loopback address pointing to 127.0.0.1 and that could be the reason for oozie unable to connect to your private IP 192.xx.xx.xx. And also could please show me the output of "oozie-setup.sh prepare-war" command.

Regards,

Sakhuja


0

cat hosts
127.0.0.1   localhost.localdomain   localhost
[cloudera@localhost etc]$ pwd
/etc
 

please let me know the location of oozie-setup.sh

cd /usr/lib/oozie/bin
[cloudera@localhost bin]$ ls
oozie  ooziedb.sh  oozied.sh  oozie-env.sh  oozie-sys.sh
 


0

Are you using cloudera sandbox?

Regards,

Sakhuja


0

Yes I am using cloudera sandbox


0

Then I know what you must try to fix it:

1. Download ext-2.2 from http://tiny.cloudera.com/oozie-ext-2.2?_ga=1.157916734.521526186.1470744899 and place this file under /var/lib/oozie directory

2. Login to your Cloudera Manager and go to Oozie service

3. Go to configuration and enable "oozie server web console" property

4. Save the changes and restart oozie

Re try and you must be able to get in the oozie web console using localhost address.


0

Thanks.

http://localhost:11000/oozie/

is working now.


0

Great!

 

Regards,

Sakhuja


0

Hi Abhishek,

Thanks for helping Subra.

Regards,

Abhijit

Your Answer

Click on this code-snippet-icon icon to add code snippet.

Upload Files (Maximum image file size - 1.5 MB, other file size - 10 MB, total size - not more than 50 MB)

Email
Password