Sqoop import error



0

Error description:

While trying to connect and import data from SQL to HDFS using Sqoop, I'm getting error as in attachment.

Appreciate any help in rectifying the error.



8 Answer(s)


0

Attached is the actual error message



0

Hi Krishnan,

Could you please share the grant permission command you have used to assign the permission and also share the cloudera version.

You need to give permission to root@<IP of vmware/virtual box>

Hope this helps.


0

Hi Abhijit,

I tried granting permissions using both 'root' and 'cloudera' as usernames but neither of them worked:

GRANT ALL PRIVILEGES ON *.* to 'root'@'<IP address of VM>' WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to root@<IP address of VM> WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to 'root'@'localhost' WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to root@localhost WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to 'root'@'localhost' IDENTIFIED BY 'cloudera' WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to 'cloudera'@'localhost' IDENTIFIED BY 'cloudera' WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* to cloudera@<IP address of VM> IDENTIFIED BY 'cloudera' WITH GRANT OPTION;

 

The cloudera VM version is 4.4.0


0

Hi Krishnan,

You need to run the following command in the command prompt:

> ipconfig

You need to check the Vmware network IP as shown in the document.

If you any doubts please share the output of ipconfig.

Hope this helps.


0

Here is the ipconfig output from where mysql is run:

Windows IP Configuration


Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Local Area Connection* 4:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : <value1>
   IPv4 Address. . . . . . . . . . . : <value2>
   Subnet Mask . . . . . . . . . . . : <value3>
   Default Gateway . . . . . . . . . :

Ethernet adapter Ethernet 2:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : <value4>
   IPv4 Address. . . . . . . . . . . : <value5>
   Subnet Mask . . . . . . . . . . . : <value6>
   Default Gateway . . . . . . . . . :

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : uwo-x-5.wireless.uwo.pri
   Link-local IPv6 Address . . . . . : <value7>
   IPv4 Address. . . . . . . . . . . : <value8>
   Subnet Mask . . . . . . . . . . . : <value8>
   Default Gateway . . . . . . . . . : <value10>

Ethernet adapter Bluetooth Network Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

 

I've used IP address (value2) under "Ethernet adapter VMware Network Adapter VMnet1". Is that correct ? I don't see the "Ethernet adapter VMware Network Adapter VMnet8" in ipconfig output as in instructions.


0

Hi Krishnan,

Thanks for sharing the information.

You need to check the vmware setting. Click on the vmware network setting and check the network name.

Read the following for reference to understand: https://www.vmware.com/support/ws4/doc/network_configure_ws.html

Note: VMnet0, VMnet1 and VMnet8 are normally used for bridged, host-only and NAT configurations.

Please check the settings. Hope this helps.


0

Hi Abhijit,

Checked the network adapter configuration and it is set as NAT. So VMnet8 should have been listed in ipconfig. However I still don't see it and not able to import data using sqoop. 


0

Hi Support Team,

Could you please suggest how to resolve it ? Thanks

Your Answer

Click on this code-snippet-icon icon to add code snippet.

Upload Files (Maximum image file size - 1.5 MB, other file size - 10 MB, total size - not more than 50 MB)

Email
Password