sqoop import in orc file format



0

Q :I am currently using   Sqoop 1.4.6-cdh5.10.0 and when i run this  scoop script 

sqoop import \

--connect "jdbc:mysql://quickstart.cloudera:3306/retail_db" \

 --username retail_dba \

 --password cloudera \

 --table departments \

 --hcatalog-home  /user/hive/warehouse/retail_ods.db/departments \

 --hcatalog-database retail_db \

 --hcatalog-table departments \

 --create-hcatalog-table \

 --hcatalog-storage-stanza 'stored as orc tblproperties ("orc.compress"="SNAPPY")'

 

 

I am getting this error:

 

 

[cloudera@quickstart ~]$ sqoop import \

> --connect "jdbc:mysql://quickstart.cloudera:3306/retail_db" \

>  --username retail_dba \

>  --password cloudera \

>  --table departments \

>  --hcatalog-home  /user/hive/warehouse/retail_ods.db/departments \

Warning: /usr/lib/sqoop/../accumulo does not exist! Accumulo imports will fail.

Please set $ACCUMULO_HOME to the root of your Accumulo installation.

18/04/27 00:02:54 INFO sqoop.Sqoop: Running Sqoop version: 1.4.6-cdh5.10.0

18/04/27 00:02:54 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.

18/04/27 00:02:54 ERROR tool.BaseSqoopTool: Error parsing arguments for import:

18/04/27 00:02:54 ERROR tool.BaseSqoopTool: Unrecognized argument: 

 

Try --help for usage instructions.

[cloudera@quickstart ~]$  --hcatalog-database retail_db \

>  --hcatalog-table departments \

>  --create-hcatalog-table \


1 Answer(s)


0

Hi Rakesh,

To properly use the Hcatalog, please refer the tutorial link:

https://www.tutorialspoint.com/hcatalog/hcatalog_introduction.htm

For installation, please refer the below:

https://www.tutorialspoint.com/hcatalog/hcatalog_installation.htm

For your error, enter the following command:

export HCAT_HOME = $HiVE_HOME/HCatalog

Hope this helps.

Thanks.